Collecting Mamiya 35mm Forum
« ZE-2 Shutter Issues »

Welcome Guest. Please Login or Register.
Jan 22nd, 2018, 3:41pm


             Click here to go to the "Collecting Mamiya 35mm Cameras" Main Web Site.

« Previous Topic | Next Topic »
Pages: 1  Notify Send Topic Print
 thread  Author  Topic: ZE-2 Shutter Issues  (Read 55 times)
tpienta
New Member
Image


member is offline

Avatar




PM


Posts: 2
xx ZE-2 Shutter Issues
« Thread started on: Dec 6th, 2017, 10:34pm »

Hey ya'll! New here! Just got a ZE-2 and it seems to be stuck in bulb mode no matter what shutter speed I select. Cannot for the life of me find any information anywhere on the google. Would greatly appreciate any possible help! Thanks!

-Tyler
User IP Logged

Pages: 1  Notify Send Topic Print
« Previous Topic | Next Topic »

NOTE: The site host for COLLECTING MAMIYA 35mm CAMERAS FORUM only provides the service for free if banner and pop-up advertising is allowed. If you really enjoy this Forum site but detest annoying pop-ups as much as I do, you now have the opportunity to help keep it ad free. Every donation of $6.99 to Conforums, the host server of this board, will keep the Forum ad-free for a month! Click below for details on how you can contribute, and thanks to the members who have already indicated their support!
Donate $6.99 for 50,000 Ad-Free Pageviews!

| |

This forum powered for FREE by Conforums ©
Sign up for your own Free Message Board today!
Terms of Service | Privacy Policy | Conforums Support | Parental Controls